summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 171d5b6..59fe2ba 100644
--- a/flake.nix
+++ b/flake.nix
@@ -14,6 +14,7 @@
inputs = {
nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
+ nixos-hardware.url = "github:NixOS/nixos-hardware";
home-manager.url = "github:nix-community/home-manager";
agenix = {
url = "github:ryantm/agenix";
@@ -42,7 +43,7 @@
hosts = attrNames (readDir ./hosts);
defaultNixosSystem = host: nixpkgs.lib.nixosSystem {
inherit system;
- specialArgs = { inherit inputs; };
+ specialArgs = { inherit inputs hosts; };
modules = [
./hosts/${host}/configuration.nix
./users/leonardo.nix