summaryrefslogtreecommitdiff
path: root/modules/basic.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/basic.nix')
-rw-r--r--modules/basic.nix16
1 files changed, 15 insertions, 1 deletions
diff --git a/modules/basic.nix b/modules/basic.nix
index 26d2e15..71404a8 100644
--- a/modules/basic.nix
+++ b/modules/basic.nix
@@ -31,7 +31,21 @@
promptInit =
''
PS1="\[\033[1;95m\][\h]\[\033[0m\] \[\033[0;32m\]\w\[\033[0m\] :: "
- [ -n "$EAT_SHELL_INTEGRATION_DIR" ] && source "$EAT_SHELL_INTEGRATION_DIR/bash"
+ vterm_printf() {
+ if [ -n "$TMUX" ] && ([ "$${TERM%%-*}" = "tmux" ] || [ "$${TERM%%-*}" = "screen" ]); then
+ # Tell tmux to pass the escape sequences through
+ printf "\ePtmux;\e\e]%s\007\e\\" "$1"
+ elif [ "$${TERM%%-*}" = "screen" ]; then
+ # GNU screen (screen, screen-256color, screen-256color-bce)
+ printf "\eP\e]%s\007\e\\" "$1"
+ else
+ printf "\e]%s\e\\" "$1"
+ fi
+ }
+ vterm_prompt_end(){
+ vterm_printf "51;A$(whoami)@$(hostname):$(pwd)"
+ }
+ PS1=$PS1'\[$(vterm_prompt_end)\]'
'';
};
programs.direnv = {