summaryrefslogtreecommitdiff
path: root/users/leonardo.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/leonardo.nix')
-rw-r--r--users/leonardo.nix14
1 files changed, 11 insertions, 3 deletions
diff --git a/users/leonardo.nix b/users/leonardo.nix
index 02f2dff..4795223 100644
--- a/users/leonardo.nix
+++ b/users/leonardo.nix
@@ -18,8 +18,9 @@
};
};
- environment.systemPackages = [
- pkgs.prismlauncher
+ environment.systemPackages = with pkgs;[
+ prismlauncher
+ rage
];
nixpkgs = {
@@ -92,7 +93,13 @@
"context.properties"."module.x11.bell" = false;
};
};
- services.openssh.enable = true;
+ services.openssh = {
+ enable = true;
+ settings = {
+ KbdInteractiveAuthentication = false;
+ PasswordAuthentication = false;
+ };
+ };
users.mutableUsers = false;
users.users.leonardo = {
isNormalUser = true;
@@ -100,6 +107,7 @@
extraGroups = [ "networkmanager" "wheel" ];
shell = pkgs.bashInteractive;
hashedPasswordFile = config.age.secrets.user-pass.path;
+ openssh.authorizedKeys.keys = builtins.attrValues (import ../secrets/hosts-pub-keys.nix);
};
age.secrets = {