summaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..5a0a226
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,28 @@
+{
+ inputs = {
+ nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
+ flake-utils.url = "github:numtide/flake-utils";
+ };
+
+ outputs = { self, flake-utils, nixpkgs }:
+ flake-utils.lib.eachDefaultSystem (system:
+ let
+ pkgs = import nixpkgs { inherit system; };
+ in {
+ devShells.default = pkgs.mkShell {
+ buildInputs = with pkgs;[
+ hugo
+ (python3.withPackages (p: [
+ p.pillow
+ ]))
+ (texlive.combine {
+ inherit (texlive) scheme-basic wrapfig etoolbox xcolor
+ enumitem supertabular titlesec multirow parskip
+ biblatex fontawesome fontawesome5
+ ;
+ })
+ ];
+ };
+ }
+ );
+}