summaryrefslogtreecommitdiff
path: root/exwm.nix
diff options
context:
space:
mode:
authorLeonardo Santiago <[email protected]>2024-03-14 16:02:18 -0300
committerLeonardo Santiago <[email protected]>2024-03-14 16:02:18 -0300
commit1ff39bc2cff34cb4aef22785d0d70bbc90efa3f5 (patch)
tree911d6570ccb3918f2839ef87dd633c91ed346874 /exwm.nix
first commit
Diffstat (limited to 'exwm.nix')
-rw-r--r--exwm.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/exwm.nix b/exwm.nix
new file mode 100644
index 0000000..df8e306
--- /dev/null
+++ b/exwm.nix
@@ -0,0 +1,25 @@
+{pkgs, inputs, system, ...}:
+{
+ services.xserver = {
+ enable = true;
+ updateDbusEnvironment = true;
+ windowManager.session = pkgs.lib.singleton {
+ name = "exwm";
+ start = ''
+ dbus-launch ${inputs.emacs.packages.x86_64-linux.default}/bin/emacs -mm
+ '';
+ };
+ desktopManager = {
+ default = "none";
+ };
+ displayManager = {
+ lightdm = {
+ enable = true;
+ };
+ autoLogin = {
+ enable = true;
+ user = "leonardo";
+ };
+ };
+ };
+}