summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorLeonardo Santiago <[email protected]>2024-05-12 11:33:54 -0300
committerLeonardo Santiago <[email protected]>2024-05-12 11:33:54 -0300
commit4f3efae46a91aae61e3d0d979670d388902d33a9 (patch)
tree7d8f2764934a76e6bc7527e7316f158c083fd9c3 /flake.nix
parentfe3eda350da50bd8d7951adf915a78fbb444b0f2 (diff)
update stuff to make new framework laptop work.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix14
1 files changed, 6 insertions, 8 deletions
diff --git a/flake.nix b/flake.nix
index e42b86d..0ea81e5 100644
--- a/flake.nix
+++ b/flake.nix
@@ -35,16 +35,14 @@
url = "github:rafaelmardojai/firefox-gnome-theme";
flake = false;
};
- mixrank.url = "git+ssh://[email protected]/mixrank/mixrank?ref=2024-05-06-hosts-in-nix";
+ #mixrank.url = "git+ssh://[email protected]/mixrank/mixrank?ref=2024-05-06-hosts-in-nix";
};
- outputs = { self, nixpkgs, home-manager, agenix, mixrank, ... } @ inputs :
+ outputs = { self, nixpkgs, home-manager, agenix, ... } @ inputs :
let
+ inherit (builtins) listToAttrs readDir attrNames;
system = "x86_64-linux";
- hosts = [
- "hanekawa" # notebook
- "kunagisa" # workstation
- ];
+ hosts = attrNames (readDir ./hosts);
defaultNixosSystem = host: nixpkgs.lib.nixosSystem {
inherit system;
specialArgs = { inherit inputs; };
@@ -53,11 +51,11 @@
./users/leonardo.nix
home-manager.nixosModules.home-manager
agenix.nixosModules.default
- mixrank.nixosModules.${system}.dev-machine
+ # mixrank.nixosModules.${system}.dev-machine
];
};
in {
- nixosConfigurations = builtins.listToAttrs
+ nixosConfigurations = listToAttrs
(map (host: {name = host; value = defaultNixosSystem host; }) hosts);
};
}