summaryrefslogtreecommitdiff
path: root/hosts/hanekawa/hardware-configuration.nix
diff options
context:
space:
mode:
authorLeonardo Santiago <[email protected]>2024-09-12 21:44:46 -0300
committerLeonardo Santiago <[email protected]>2024-09-12 23:20:51 -0300
commit62100c9265a4de389d1ea8060cbddddacde161a7 (patch)
tree811ca1c5803ccdb2670f0c239214bc0dc30f57c7 /hosts/hanekawa/hardware-configuration.nix
parentf9ddec7952709d7b5d5d79deadca07c573510d49 (diff)
split users/leonardo.nix into modules with options
in order to be able to deploy just a few of those to iori.nix
Diffstat (limited to 'hosts/hanekawa/hardware-configuration.nix')
-rw-r--r--hosts/hanekawa/hardware-configuration.nix77
1 files changed, 0 insertions, 77 deletions
diff --git a/hosts/hanekawa/hardware-configuration.nix b/hosts/hanekawa/hardware-configuration.nix
deleted file mode 100644
index 2b11bd6..0000000
--- a/hosts/hanekawa/hardware-configuration.nix
+++ /dev/null
@@ -1,77 +0,0 @@
-# Do not modify this file! It was generated by ‘nixos-generate-config’
-# and may be overwritten by future invocations. Please make changes
-# to /etc/nixos/configuration.nix instead.
-{ config, lib, pkgs, modulesPath, ... }:
-
-{
- imports = [
- (modulesPath + "/installer/scan/not-detected.nix")
-
- ];
- boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "nvme" "usb_storage" "sd_mod" ];
- boot.initrd.kernelModules = [ ];
-
- boot.kernelModules = [
- "kvm-intel"
- "i915"
- ];
- boot.kernelParams = [
- "acpi_osi=Linux-Dell-Video"
- ];
- boot.extraModulePackages = [ ];
-
- fileSystems."/" =
- { device = "/dev/disk/by-uuid/36536f52-8ca1-4a1e-b418-4016e529ea97";
- fsType = "ext4";
- };
-
- fileSystems."/boot" =
- { device = "/dev/disk/by-uuid/6021-0AF8";
- fsType = "vfat";
- };
-
- swapDevices =
- [ { device = "/dev/disk/by-uuid/51402149-30c4-475c-af19-c5d600b1ee8e"; }
- ];
-
-
-
- hardware = {
- opengl = {
- enable = true;
- driSupport = true;
- driSupport32Bit = true;
- };
- pulseaudio.enable = false;
- nvidia = {
- modesetting.enable = true;
- powerManagement = { enable = false; finegrained = false; };
- open = false;
- nvidiaSettings = true;
- prime = {
- offload = {
- enable = true;
- enableOffloadCmd = true;
- };
- sync.enable = false;
- reverseSync.enable = false;
- intelBusId = "PCI:0:2:0";
- nvidiaBusId = "PCI:1:0:0";
- };
- };
- opengl.extraPackages = [ pkgs.vaapiVdpau ];
-
- };
-
- # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
- # (the default) this is the recommended approach. When using systemd-networkd it's
- # still possible to use this option, but it's recommended to use it in conjunction
- # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
- networking.useDHCP = lib.mkDefault true;
- # networking.interfaces.enp3s0.useDHCP = lib.mkDefault true;
- # networking.interfaces.wlp4s0.useDHCP = lib.mkDefault true;
-
- nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
- powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
- hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
-}