summaryrefslogtreecommitdiff
path: root/hosts/kunagisa.nix
diff options
context:
space:
mode:
authorLeonardo Santiago <[email protected]>2024-09-12 21:44:46 -0300
committerLeonardo Santiago <[email protected]>2024-09-12 23:20:51 -0300
commit62100c9265a4de389d1ea8060cbddddacde161a7 (patch)
tree811ca1c5803ccdb2670f0c239214bc0dc30f57c7 /hosts/kunagisa.nix
parentf9ddec7952709d7b5d5d79deadca07c573510d49 (diff)
split users/leonardo.nix into modules with options
in order to be able to deploy just a few of those to iori.nix
Diffstat (limited to 'hosts/kunagisa.nix')
-rw-r--r--hosts/kunagisa.nix52
1 files changed, 52 insertions, 0 deletions
diff --git a/hosts/kunagisa.nix b/hosts/kunagisa.nix
new file mode 100644
index 0000000..60d7d65
--- /dev/null
+++ b/hosts/kunagisa.nix
@@ -0,0 +1,52 @@
+# Edit this configuration file to define what should be installed on
+# your system. Help is available in the configuration.nix(5) man page
+# and in the NixOS manual (accessible by running ‘nixos-help’).
+
+{ config, pkgs, lib, modulesPath, inputs, ... }: {
+ imports = [
+ inputs.mixrank.nixosModules.dev-machine
+ (modulesPath + "/installer/scan/not-detected.nix")
+ ];
+ santi-modules.desktop-environment.enable = true;
+ # Bootloader.
+ boot = {
+ loader = {
+ systemd-boot.enable = true;
+ efi.canTouchEfiVariables = true;
+ };
+ initrd = {
+ availableKernelModules = [ "nvme" "xhci_pci" "ahci" "usbhid" ];
+ kernelModules = [ "amdgpu" ];
+ };
+ binfmt.emulatedSystems = [ "aarch64-linux" ];
+ kernelModules = [ "kvm-amd" ];
+ kernelPackages = pkgs.linuxPackages_latest;
+ extraModulePackages = [ ];
+ };
+
+ networking = {
+ hostName = "kunagisa"; # Define your hostname.
+ networkmanager.enable = true;
+ firewall.enable = false;
+ useDHCP = lib.mkDefault true;
+ };
+
+ nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+
+ fileSystems = {
+ "/" = {
+ device = "/dev/disk/by-uuid/96c114a2-ffd7-476d-80fa-51e670c27e4b";
+ fsType = "ext4";
+ };
+ "/boot" = {
+ device = "/dev/disk/by-uuid/AA22-4A81";
+ fsType = "vfat";
+ };
+ };
+
+ swapDevices = [
+ { device = "/dev/disk/by-uuid/1a204e5c-05cb-4e7f-b859-927fb024fb12"; }
+ ];
+ hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+ system.stateVersion = "23.05";
+}