summaryrefslogtreecommitdiff
path: root/hosts/kunagisa/configuration.nix
diff options
context:
space:
mode:
authorLeonardo Santiago <[email protected]>2024-03-14 16:02:18 -0300
committerLeonardo Santiago <[email protected]>2024-03-14 16:02:18 -0300
commit1ff39bc2cff34cb4aef22785d0d70bbc90efa3f5 (patch)
tree911d6570ccb3918f2839ef87dd633c91ed346874 /hosts/kunagisa/configuration.nix
first commit
Diffstat (limited to 'hosts/kunagisa/configuration.nix')
-rw-r--r--hosts/kunagisa/configuration.nix86
1 files changed, 86 insertions, 0 deletions
diff --git a/hosts/kunagisa/configuration.nix b/hosts/kunagisa/configuration.nix
new file mode 100644
index 0000000..b9b669a
--- /dev/null
+++ b/hosts/kunagisa/configuration.nix
@@ -0,0 +1,86 @@
+# Edit this configuration file to define what should be installed on
+# your system. Help is available in the configuration.nix(5) man page
+# and in the NixOS manual (accessible by running ‘nixos-help’).
+
+{ config, pkgs, inputs, ... }:
+
+{
+ imports =
+ [ # Include the results of the hardware scan.
+ ./hardware-configuration.nix
+ ];
+
+ # Bootloader.
+ boot.loader.systemd-boot.enable = true;
+ boot.loader.efi.canTouchEfiVariables = true;
+ boot.binfmt.emulatedSystems = [ "aarch64-linux" ];
+
+ networking.hostName = "kunagisa"; # Define your hostname.
+ # networking.wireless.enable = true; # Enables wireless support via wpa_supplicant.
+
+ # Configure network proxy if necessary
+ # networking.proxy.default = "http://user:password@proxy:port/";
+ # networking.proxy.noProxy = "127.0.0.1,localhost,internal.domain";
+
+ # Enable networking
+ networking.networkmanager.enable = true;
+
+ # Set your time zone.
+ time.timeZone = "America/Sao_Paulo";
+
+ # Select internationalisation properties.
+ i18n.defaultLocale = "pt_BR.UTF-8";
+
+ # Enable the X11 windowing system.
+ services.xserver = {
+ enable = true;
+ xkb = {
+ variant = "";
+ layout = "br";
+ };
+ };
+
+ # Configure console keymap
+ console.keyMap = "br-abnt2";
+
+ # Enable CUPS to print documents.
+ services.printing.enable = true;
+
+ # Enable sound with pipewire.
+ sound.enable = true;
+ hardware.pulseaudio.enable = false;
+ security.rtkit.enable = true;
+ services.pipewire = {
+ enable = true;
+ alsa.enable = true;
+ alsa.support32Bit = true;
+ pulse.enable = true;
+ # If you want to use JACK applications, uncomment this
+ #jack.enable = true;
+
+ # use the example session manager (no others are packaged yet so this is enabled by default,
+ # no need to redefine it in your config for now)
+ #media-session.enable = true;
+ };
+
+ # Enable touchpad support (enabled default in most desktopManager).
+ # services.xserver.libinput.enable = true;
+
+ # Open ports in the firewall.
+ # networking.firewall.allowedTCPPorts = [ ... ];
+ # networking.firewall.allowedUDPPorts = [ ... ];
+ # Or disable the firewall altogether.
+ # networking.firewall.enable = false;
+ networking.firewall = {
+ enable = false;
+ # allowedTCPPorts = [ 12345 ];
+ };
+
+ # This value determines the NixOS release from which the default
+ # settings for stateful data, like file locations and database versions
+ # on your system were taken. It‘s perfectly fine and recommended to leave
+ # this value at the release version of the first install of this system.
+ # Before changing this value read the documentation for this option
+ # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
+ system.stateVersion = "23.05"; # Did you read the comment?
+}