summaryrefslogtreecommitdiff
path: root/modules/cgit.nix
diff options
context:
space:
mode:
authorLeonardo Santiago <[email protected]>2024-10-28 08:05:42 -0300
committerLeonardo Santiago <[email protected]>2024-10-28 08:05:42 -0300
commit4842e81317e9815540d559d689be51d13191e1e4 (patch)
treed1b97123d3aaea731544e238d89af3e1ccfe9d29 /modules/cgit.nix
parentfbbf34c7b6ba70a718abf655c0711b6ac5ff20e8 (diff)
change files to web-services in order to share some code.
Diffstat (limited to 'modules/cgit.nix')
-rw-r--r--modules/cgit.nix38
1 files changed, 0 insertions, 38 deletions
diff --git a/modules/cgit.nix b/modules/cgit.nix
deleted file mode 100644
index fb894b8..0000000
--- a/modules/cgit.nix
+++ /dev/null
@@ -1,38 +0,0 @@
-{ config, lib, pkgs, ...}: with lib; {
- options.santi-modules.services.cgit.enable = mkEnableOption "Enable cgit instance";
- config = mkIf config.santi-modules.services.cgit.enable {
- services.cgit.santi = let
- org2html = pkgs.writeShellScript "org2md" ''
- ${pkgs.pandoc}/bin/pandoc \
- --from org \
- --to html5 \
- --sandbox=true \
- --html-q-tags \
- --ascii \
- --standalone \
- --wrap=auto \
- --embed-resources \
- -M document-css=false
- '';
- in {
- enable = true;
- user = "root";
- group = "root";
- settings = {
- readme = ":README.org";
- root-title = "index";
- root-desc = "public repositories for santi.net.br";
- about-filter = toString org2html;
- enable-git-config = true;
- enable-html-cache = false;
- enable-blame = true;
- enable-log-linecount = true;
- enable-index-links = true;
- enable-index-owner = false;
- enable-commit-graph = true;
- remove-suffix = true;
- };
- scanPath = "/home/leonardo";
- };
- };
-}