summaryrefslogtreecommitdiff
path: root/modules/ddns.nix
diff options
context:
space:
mode:
authorLeonardo Santiago <[email protected]>2024-10-25 20:07:38 -0300
committerLeonardo Santiago <[email protected]>2024-10-25 20:07:38 -0300
commitfbbf34c7b6ba70a718abf655c0711b6ac5ff20e8 (patch)
tree5b595f587cb38272b9e23a8a0ba6fd7c95a7896b /modules/ddns.nix
parent01b442dee4d7d3d2b404a17d0e9adeb66593a54b (diff)
partial commit
Diffstat (limited to 'modules/ddns.nix')
-rw-r--r--modules/ddns.nix13
1 files changed, 12 insertions, 1 deletions
diff --git a/modules/ddns.nix b/modules/ddns.nix
index 53dcb0f..3a3196e 100644
--- a/modules/ddns.nix
+++ b/modules/ddns.nix
@@ -1,6 +1,17 @@
-{ config, lib, pkgs, ...}: with lib; {
+{ config, lib, ...}: with lib; {
options.santi-modules.services.ddns.enable = mkEnableOption "Enable ddns service";
config = mkIf config.santi-modules.services.ddns.enable {
+ networking.enableIPv6 = true;
+ services.cloudflared = {
+ enable = true;
+ tunnels.iori = {
+ default = "http_status:404";
+ credentialsFile = "/var/lib/cloudflared/iori.json";
+ ingress = {
+ "santi.net.br" = "http://localhost:80";
+ };
+ };
+ };
services.inadyn = {
enable = true;
user = "leonardo";