summaryrefslogtreecommitdiff
path: root/users/leonardo.nix
diff options
context:
space:
mode:
authorLeonardo Santiago <[email protected]>2024-08-19 09:38:29 -0300
committerLeonardo Santiago <[email protected]>2024-08-19 09:38:29 -0300
commitad31831c7c9d934aefdbec38d9c3f8a09e1d6208 (patch)
treec9907ab65d98f34b13864dd182c44ddd59073469 /users/leonardo.nix
parent9a540319df87f8df75266dec9986e1735a44a226 (diff)
update stuff
Diffstat (limited to 'users/leonardo.nix')
-rw-r--r--users/leonardo.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/users/leonardo.nix b/users/leonardo.nix
index c858494..ed59bf2 100644
--- a/users/leonardo.nix
+++ b/users/leonardo.nix
@@ -1,7 +1,6 @@
{ pkgs, config, inputs, ... }:
let
hosts-pub-keys = import ../secrets/host-pub-keys.nix;
- host-key = hosts-pub-keys.${config.networking.hostName};
in
{
imports = [
@@ -10,9 +9,9 @@ in
];
config = {
nix = {
+ package = pkgs.lib.mkForce pkgs.nixVersions.nix_2_23;
settings = {
trusted-users = [ "root" "leonardo" ];
- experimental-features = "nix-command flakes";
auto-optimise-store = true;
};
gc = {
@@ -26,7 +25,8 @@ in
prismlauncher
rage
];
-
+
+
nixpkgs = {
config.allowUnfree = true;
config.allowUnfreePredicate = _: true;