summaryrefslogtreecommitdiff
path: root/hosts/iori.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/iori.nix')
-rw-r--r--hosts/iori.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/hosts/iori.nix b/hosts/iori.nix
new file mode 100644
index 0000000..896f836
--- /dev/null
+++ b/hosts/iori.nix
@@ -0,0 +1,37 @@
+# Edit this configuration file to define what should be installed on
+# your system. Help is available in the configuration.nix(5) man page, on
+# https://search.nixos.org/options and in the NixOS manual (`nixos-help`).
+
+{ lib, inputs, modulesPath, ... }:
+
+{
+ imports = [ # Include the results of the hardware scan.
+ inputs.nixos-hardware.nixosModules.raspberry-pi-4
+ (modulesPath + "/installer/scan/not-detected.nix")
+ ];
+
+ santi-modules = {
+ default-user.enable = true;
+ basic.enable = true;
+ font-config.enable = false;
+ services.ddns.enable = true;
+ };
+
+ boot = {
+ loader.grub.enable = false;
+ loader.generic-extlinux-compatible.enable = true;
+ initrd.availableKernelModules = [ "xhci_pci" ];
+ };
+
+ fileSystems."/" = {
+ device = "/dev/disk/by-uuid/44444444-4444-4444-8888-888888888888";
+ fsType = "ext4";
+ };
+
+ networking = {
+ hostName = "iori"; # Define your hostname.
+ useDHCP = lib.mkDefault true;
+ };
+ nixpkgs.hostPlatform = lib.mkDefault "aarch64-linux";
+ system.stateVersion = "24.05"; # Did you read the comment?
+}