summaryrefslogtreecommitdiff
path: root/hosts/larissa/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/larissa/configuration.nix')
-rw-r--r--hosts/larissa/configuration.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/hosts/larissa/configuration.nix b/hosts/larissa/configuration.nix
new file mode 100644
index 0000000..b007ebd
--- /dev/null
+++ b/hosts/larissa/configuration.nix
@@ -0,0 +1,21 @@
+{ config, pkgs, lib, ... }:
+{
+ imports =
+ [
+ <nixos-hardware/raspberry-pi/4>
+ ./hardware-configuration.nix
+ ];
+ hardware = {
+ raspberry-pi."4".apply-overlays-dtmerge.enable = true;
+ deviceTree = {
+ enable = true;
+ filter = "*rpi-4-*.dtb";
+ };
+ };
+ console.enable = false;
+ environment.systemPackages = with pkgs; [
+ libraspberrypi
+ raspberrypi-eeprom
+ ];
+ system.stateVersion = "23.11";
+}