summaryrefslogtreecommitdiff
path: root/modules/blog.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/blog.nix')
-rw-r--r--modules/blog.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/modules/blog.nix b/modules/blog.nix
index 9234f4e..6e7021a 100644
--- a/modules/blog.nix
+++ b/modules/blog.nix
@@ -19,11 +19,19 @@ in {
};
};
config = mkIf cfg.enable {
- networking.firewall.allowedTCPPorts = [ 80 ];
+ networking.firewall.allowedTCPPorts = [ 80 443 ];
# TODO: enable SSL
services.nginx = {
enable = true;
- virtualHosts.${cfg.url}.root = blog;
+ virtualHosts.${cfg.url} = {
+ addSSL = true;
+ enableACME = true;
+ root = blog;
+ };
+ };
+ security.acme = {
+ acceptTerms = true;
+ certs."santi.net.br".email = "[email protected]";
};
};
}