summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorLeonardo Santiago <[email protected]>2024-06-25 10:24:46 -0300
committerLeonardo Santiago <[email protected]>2024-06-25 10:24:59 -0300
commit94e28dca93f8481715728b006943a791fdafda9e (patch)
tree885ce13346799f737b17d34b453b344ebc852e85 /flake.nix
parent5b7c730721098a82546b8538e96d415ba5e8d914 (diff)
initial commit for rpi4
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 59fe2ba..c35fc49 100644
--- a/flake.nix
+++ b/flake.nix
@@ -53,7 +53,15 @@
];
};
in {
- nixosConfigurations = listToAttrs
- (map (host: {name = host; value = defaultNixosSystem host; }) hosts);
+ nixosConfigurations =
+ (listToAttrs (map (host: {name = host; value = defaultNixosSystem host; }) hosts))
+ // { iori = nixpkgs.lib.nixosSystem {
+ system = "aarch64-linux";
+ specialArgs = { inherit inputs; };
+ modules = [
+ ./hosts/iori/configuration.nix
+ ];
+ };
+ };
};
}